Connectivity issues
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Aug 24, 2016 - 16:22 EDT
Monitoring
Systems have returned to normal. We are monitoring closely.
Posted Aug 24, 2016 - 16:14 EDT
Investigating
We are investigating site access issues on all sites.
Posted Aug 24, 2016 - 15:04 EDT