Connectivity Issues
Incident Report for Squarespace
Resolved
This incident has been resolved and we have confirmed that all systems are operational. Thank you for your patience.
Posted Oct 29, 2018 - 19:06 EDT
Monitoring
A resolution has been implemented and we are monitoring closely before resolving the issue.
Posted Oct 29, 2018 - 19:02 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 29, 2018 - 18:43 EDT
Investigating
We've confirmed that images and the add to cart button aren't loading on some sites. Our engineers are currently deploying a fix. q
Posted Oct 29, 2018 - 18:43 EDT
This incident affected: Site Loading.