Some customers unable to log in via account dashboard
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Nov 15, 2019 - 09:40 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 15, 2019 - 09:27 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 15, 2019 - 09:17 EST
Investigating
We are investigating an issue where some customers are unable to log in via the account dashboard.
Posted Nov 15, 2019 - 09:06 EST
This incident affected: Site Loading and Commerce.