Merchants unable to connect PayPal
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Apr 02, 2020 - 14:57 EDT
Update
We are continuing to investigate this issue.
Posted Apr 02, 2020 - 11:48 EDT
Update
Thanks for your patience as we continue to investigate this issue with connecting PayPal as a payment processor. In the interim, we have enabled manual connection for all merchants regardless of country. See our guide for details: http://sqsp.link/IvpzPt
Posted Apr 02, 2020 - 11:11 EDT
Investigating
We're investigating issues with connecting PayPal for some merchants
Posted Apr 02, 2020 - 10:54 EDT
This incident affected: Commerce.