Customers Panel Missing Contact Details
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Feb 28, 2020 - 08:53 EST
Update
We are continuing to work on a fix for this issue.
Posted Feb 28, 2020 - 08:09 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 28, 2020 - 07:47 EST
Investigating
We're currently investigating an issue with the Customers Panel.
Posted Feb 28, 2020 - 06:52 EST
This incident affected: Commerce.