Login Issues
Incident Report for Squarespace
Resolved
No new reports on customer login issues.
Posted Feb 04, 2019 - 20:11 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 04, 2019 - 19:25 EST
Update
We are continuing to investigate the login issue.
Posted Feb 04, 2019 - 18:30 EST
Investigating
We are currently investigating an issue affecting customer logins.
Posted Feb 04, 2019 - 16:22 EST
This incident affected: Site Loading.