Payment Processor Elevated Error Rates
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Feb 06, 2019 - 16:30 EST
Monitoring
We have identified an issue of elevated error rates with our payment processor. We will post updates as we are made aware.
Posted Feb 06, 2019 - 13:10 EST
This incident affected: Commerce.