Login Issues
Incident Report for Squarespace
Resolved
This incident has been resolved and we have confirmed that customers logins are now functioning normally. Thank you for your patience.
Posted Jun 16, 2017 - 17:35 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 16, 2017 - 17:05 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 16, 2017 - 16:09 EDT
Investigating
We are currently investigating an issue affecting customer logins.
Posted Jun 16, 2017 - 15:35 EDT