Some users unable to access Account Dashboard
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Feb 13, 2021 - 11:19 EST
Update
We are continuing to work on a fix for this issue.
Posted Feb 13, 2021 - 11:05 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 13, 2021 - 10:48 EST
Update
We are continuing to investigate this issue.
Posted Feb 13, 2021 - 10:36 EST
Investigating
We are currently investigating this issue.
Posted Feb 13, 2021 - 10:21 EST
This incident affected: Accounts & Billing.