Connectivity Issues
Incident Report for Squarespace
Resolved
This incident has been resolved and we have confirmed that all systems are operational. Thank you for your patience.
Posted Sep 11, 2017 - 16:47 EDT
Monitoring
A resolution has been implemented and we are monitoring closely before resolving the issue.
Posted Sep 11, 2017 - 16:22 EDT
Investigating
We are investigating connectivity issues related to most Squarespace sites. We will provide more information as soon as possible.
Posted Sep 11, 2017 - 15:22 EDT