Connectivity issues

Incident Report for Squarespace

Postmortem

On Tuesday, March 31st, 2026, many Squarespace websites experienced unavailability for an aggregate of 53 minutes, between 4:43 PM and 5:36 PM EDT. During this incident, we failed to serve approximately 28% of customer requests. Site visitors saw slow loads or “Service Unavailable” errors impacting site loading, login, site editing, Campaigns, Domains, and our Commerce platform.

At 4:43 PM EDT we performed a network configuration change in one of our points of presence (PoP). This change impacted critical networking equipment within that region. Our teams were notified immediately via automated alerts, internal reports, and additional customer reports.

At 4:48 PM EDT our system automatically routed traffic off of this PoP. This action should have contained the impact. However, another region was already offline due to planned maintenance. As a result, the majority of our traffic was ultimately routed to a single PoP. In aggregate, this increased load overwhelmed our website lookup infrastructure in this region, severely impacting visitor requests.

At 5:08 PM EDT, our teams resolved the original network configuration issue. We continued to see customer impact, so at 5:20 PM EDT we cleared the website lookup cache in the active region. This exacerbated the issue due to an additional misconfiguration within the lookup infrastructure. 

At 5:35 PM EDT we successfully routed traffic back onto the original PoP, which had fully recovered. By 5:36 PM EDT our systems were serving all customer requests normally.

We deeply apologize for this incident. Ensuring Squarespace sites remain up and available is of the utmost importance to us. Our team has prioritized improvements to the mitigation of similar issues and scaling our edge capacity as necessary. Thank you for your patience.

Posted Apr 07, 2026 - 13:42 EDT

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 18:01 EDT

Update

Issue has been mitigated as of 5:36pm EDT. We are continuing to monitor for any further issues.
Posted Mar 31, 2026 - 17:49 EDT

Update

We're investigating errors while connecting to some Squarespace sites.
Posted Mar 31, 2026 - 17:45 EDT

Monitoring

We're investigating errors while connecting to some Squarespace sites.
Posted Mar 31, 2026 - 17:44 EDT

Update

We're investigating errors while connecting to some Squarespace sites.
Posted Mar 31, 2026 - 17:26 EDT

Investigating

We're investigating errors while connecting to some Squarespace sites.
Posted Mar 31, 2026 - 17:06 EDT