Customers unable to register domains
Incident Report for Squarespace
Resolved
We've fixed the issue. Domain registration is working again.
Posted Nov 15, 2019 - 07:24 EST
Update
We're still working on a fix for this issue.
Posted Nov 15, 2019 - 07:07 EST
Identified
We have identified the issue and are working on a fix.
Posted Nov 15, 2019 - 06:09 EST
Update
We are still investigating this issue.
Posted Nov 15, 2019 - 05:44 EST
Update
We are still investigating this issue.
Posted Nov 15, 2019 - 05:28 EST
Investigating
We are investigating an issue where customers are unable to register domains.
Posted Nov 15, 2019 - 05:13 EST
This incident affected: Domains.