Customers will see errors with domain transfers

Incident Report for Squarespace

Resolved

This incident has been resolved.
Posted Mar 06, 2026 - 08:31 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 06, 2026 - 07:49 EST

Investigating

We are investigating domain transfers issues. Customers might not be able to review and manage domains that are pending transfer to Squarespace.
Posted Mar 06, 2026 - 07:48 EST
This incident affected: Domains.