[Connected Accounts] Elevated Error Rates On Connection
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Jul 10, 2019 - 16:19 EDT
Investigating
We are investigating reports of elevated error rates.
Posted Jul 10, 2019 - 16:13 EDT
This incident affected: Site Loading.