Header content overlapping on some sites
Incident Report for Squarespace
Resolved
This issue has been resolved
Posted Dec 14, 2019 - 12:17 EST
Update
We are continuing to work on the fix for this issue.
Posted Dec 14, 2019 - 11:57 EST
Identified
We have identified the problem and are testing a fix.
Posted Dec 14, 2019 - 11:39 EST
Update
We are continuing to investigate the issue.
Posted Dec 14, 2019 - 11:34 EST
Investigating
We are investigating reports of overlapping header content on some sites
Posted Dec 14, 2019 - 11:25 EST