HTTPS certificate generation and renewal is delayed
Incident Report for Squarespace
Resolved
All delayed certificates have been successfully generated. This incident is now resolved.
Posted Jan 11, 2018 - 10:45 EST
Monitoring
SSL/TLS certificate generation operations are returning to normal. We will continue to monitor closely to ensure that all delayed certificates are properly generated.
Posted Jan 11, 2018 - 00:48 EST
Investigating
Due to a problem external to Squarespace, SSL/TLS certificate generation for new domains is delayed. The problem is also delaying SSL/TLS certificate renewal for existing domains. We're in touch with our certificate authority partner and they are working to resolve this issue.
Posted Jan 10, 2018 - 00:40 EST