Domain registration failures
Incident Report for Squarespace
Resolved
Domain registration is working properly now.
Posted Oct 11, 2016 - 06:03 EDT
Identified
We have identified an issue with DNS registration which impacts domain registration.
Posted Oct 11, 2016 - 05:51 EDT
Investigating
We are investigating reports of domain registration failing.
Posted Oct 11, 2016 - 05:30 EDT