Domain Registration / Searching Issues
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Nov 08, 2019 - 07:20 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 08, 2019 - 07:13 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 08, 2019 - 06:30 EST
Investigating
We are investigating issues with domain registrations and will provide updates as soon as possible.
Posted Nov 08, 2019 - 05:33 EST
This incident affected: Domains.