Acuity Scheduling / Webhook delivery delay

Incident Report for Squarespace

Resolved

The issue with delayed webhook delivery has been resolved.
Posted Feb 11, 2026 - 10:57 EST

Identified

We have identified the cause of the webhook delivery delay, and are working toward a solution.
Posted Feb 11, 2026 - 09:44 EST

Investigating

We are currently investigating a delay in webhook delivery.
Posted Feb 11, 2026 - 09:08 EST