Connectivity issues
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Oct 19, 2016 - 06:48 EDT
Monitoring
We believe these connectivity issues are due to network issues external to Squarespace. This issue will be closed. If you experience further issues, please contact Customer Care.
Posted Oct 19, 2016 - 06:40 EDT
Update
We have received a few more isolated reports of browser timeouts when visiting sites. Our engineers have not confirmed any problems across our system.
Posted Oct 19, 2016 - 06:33 EDT
Investigating
We are investigating several reports of connectivity issues.
Posted Oct 19, 2016 - 05:25 EDT