Page load issues
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Apr 11, 2018 - 06:45 EDT
Monitoring
Most sites now load properly. The system should fully recover in a few minutes. We are monitoring to ensure the issue is fully resolved.
Posted Apr 11, 2018 - 05:27 EDT
Identified
We have identified an issue in our domain routing layer affecting some customers. A team is working on a resolution.
Posted Apr 11, 2018 - 05:02 EDT
Investigating
We are investigating page load issues affecting some Squarespace sites. We will provide more information as soon as possible.
Posted Apr 11, 2018 - 04:26 EDT