All Systems Operational

About This Site

Welcome to Squarespace's home for service status updates.

Site Loading Operational
90 days ago
100.0 % uptime
Today
Site Editing Operational
90 days ago
100.0 % uptime
Today
Commerce Operational
90 days ago
99.98 % uptime
Today
Domains Operational
90 days ago
100.0 % uptime
Today
Email Campaigns Operational
90 days ago
99.88 % uptime
Today
Acuity Scheduling Operational
90 days ago
99.97 % uptime
Today
Accounts & Billing Operational
90 days ago
100.0 % uptime
Today
Analytics Operational
90 days ago
100.0 % uptime
Today
Google Workspace Operational
90 days ago
100.0 % uptime
Today
Third Party Services Operational
90 days ago
100.0 % uptime
Today
Developer Platform Operational
90 days ago
100.0 % uptime
Today
Squarespace Help Operational
90 days ago
100.0 % uptime
Today
Forum Operational
90 days ago
100.0 % uptime
Today
Domain Reseller API ? Operational
90 days ago
100.0 % uptime
Today
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Major outage
Partial outage
No downtime recorded on this day.
No data exists for this day.
had a major outage.
had a partial outage.
Apr 7, 2025

No incidents reported today.

Apr 6, 2025

No incidents reported.

Apr 5, 2025

No incidents reported.

Apr 4, 2025
Resolved - This incident has been resolved.
Apr 4, 20:38 EDT
Monitoring - A fix has been implemented and we are monitoring the results.
Apr 4, 20:05 EDT
Update - We are still continuing to work on implementing a fix for this issue.
Apr 4, 19:47 EDT
Update - We are continuing to work on a fix for this issue.
Apr 4, 16:52 EDT
Identified - The issue has been identified and a fix is being implemented.
Apr 4, 15:00 EDT
Investigating - We are currently investigating this issue.
Apr 4, 14:39 EDT
Apr 3, 2025

No incidents reported.

Apr 2, 2025

No incidents reported.

Apr 1, 2025
Resolved - This incident has been resolved.
Apr 1, 20:31 EDT
Monitoring - A fix has been implemented and we are monitoring the results.
Apr 1, 20:04 EDT
Identified - The issue has been identified and a fix is being implemented.
Apr 1, 19:56 EDT
Update - We are continuing to investigate the issue.
Apr 1, 19:27 EDT
Investigating - We are currently investigating an issue with the Email Campaigns panel showing a something went wrong error.
Apr 1, 19:07 EDT
Mar 31, 2025

No incidents reported.

Mar 30, 2025

No incidents reported.

Mar 29, 2025

No incidents reported.

Mar 28, 2025

No incidents reported.

Mar 27, 2025
Resolved - This incident has been resolved.
Mar 27, 17:36 EDT
Update - We are continuing to work on a fix for this issue.
Mar 27, 16:42 EDT
Update - We are continuing to work on a fix for this issue.
Mar 27, 16:05 EDT
Update - We are continuing to work on a fix for this issue.
Mar 27, 15:46 EDT
Identified - The issue has been identified and a fix is being implemented.
Mar 27, 14:46 EDT
Investigating - We are currently investigating this issue.
Mar 27, 14:04 EDT
Mar 26, 2025

No incidents reported.

Mar 25, 2025

No incidents reported.

Mar 24, 2025

No incidents reported.