Squarespace Scheduling latency
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Nov 15, 2021 - 14:57 EST
Monitoring
We're investigating issues loading Scheduling.
Posted Nov 15, 2021 - 14:29 EST
This incident affected: Scheduling.