Website Rendering Issues
Incident Report for Squarespace
Resolved
This incident has been resolved and we have confirmed that all systems are operational. Thank you for your patience.
Posted Feb 17, 2017 - 13:28 EST
Monitoring
A resolution has been implemented and we are monitoring closely before resolving the issue.
Posted Feb 17, 2017 - 13:15 EST
Identified
We have identified an issue with CSS on some sites and are implementing a resolution.
Posted Feb 17, 2017 - 12:58 EST