Acuity Scheduling - Clients of businesses may not be able to update card...

Incident Report for Squarespace

Resolved

Acuity Scheduling is now fully operational.
Posted Mar 31, 2026 - 14:37 EDT

Update

We are currently experiencing a service disruption.

Our Engineering team has identified the root cause and is working to implement a solution. All users may be affected.

We will provide an update as soon as possible.
Posted Mar 31, 2026 - 14:26 EDT

Identified

We are currently experiencing a service disruption.

Our Engineering team is working to identify the root cause and implement a solution. All users may be affected.

We will provide an update as soon as possible.
Posted Mar 31, 2026 - 14:00 EDT

Investigating

We are currently experiencing a service disruption.

Our Engineering team is working to identify the root cause and implement a solution. All users may be affected.

We will provide an update as soon as possible.
Posted Mar 31, 2026 - 13:40 EDT