Template installation isn’t working for some customers
Incident Report for Squarespace
Resolved
This incident has been resolved
Posted Feb 04, 2020 - 19:42 EST
Identified
We have identified the issue and we are working on a fix
Posted Feb 04, 2020 - 19:32 EST
Investigating
We are currently investigating the issue
Posted Feb 04, 2020 - 19:18 EST