Support Center Outage
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Apr 12, 2019 - 12:33 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 12, 2019 - 11:53 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 12, 2019 - 11:03 EDT
Investigating
We’re experiencing issues with our Support Center. We’re working to resolve this and thank you for your patience.
Posted Apr 12, 2019 - 11:02 EDT
This incident affected: Squarespace Help.