Some Commerce features are failing to load

Incident Report for Squarespace

Resolved

This incident has been resolved.
Posted Sep 03, 2025 - 19:33 EDT

Update

We have mitigated the issue that was preventing some Commerce features from loading.
Posted Sep 03, 2025 - 18:05 EDT

Update

We're continuing to investigate an issue that is preventing some Commerce features from loading.
Posted Sep 03, 2025 - 17:32 EDT

Update

We're continuing to investigate an issue that is preventing some Commerce features from loading.
Posted Sep 03, 2025 - 17:16 EDT

Update

We're continuing to investigate an issue that is preventing some Commerce features from loading.
Posted Sep 03, 2025 - 17:02 EDT

Investigating

We're currently investigating an issue that is preventing some Commerce features from loading.
Posted Sep 03, 2025 - 16:39 EDT
This incident affected: Site Loading and Commerce.