Connectivity Issues
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Feb 07, 2019 - 17:38 EST
Monitoring
A resolution has been implemented and we are monitoring closely before resolving the issue.
Posted Feb 07, 2019 - 17:05 EST
Investigating
We are investigating connectivity issues related to most Squarespace sites. We will provide more information as soon as possible.
Posted Feb 07, 2019 - 16:38 EST
This incident affected: Site Loading, Commerce, and Developer Platform.