Connectivity Issues
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted May 23, 2017 - 18:46 EDT
Monitoring
A resolution has been implemented and we are monitoring closely before resolving the issue.
Posted May 23, 2017 - 18:15 EDT
Identified
We have identified an issue with our database layer and we are implementing a resolution.
Posted May 23, 2017 - 16:12 EDT
Investigating
We are investigating connectivity issues related to most Squarespace sites.
Posted May 23, 2017 - 15:48 EDT