Users unable to add images to site from Getty and Unsplash
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Nov 23, 2020 - 16:02 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 23, 2020 - 15:10 EST
Investigating
We are currently investing this issue.
Posted Nov 23, 2020 - 15:07 EST
This incident affected: Site Editing.