Domain Registration / Searching Issues
Incident Report for Squarespace
Resolved
This incident has been resolved, thank you for your patience.
Posted Apr 25, 2019 - 13:24 EDT
Identified
We have identified issues with users making changes to their domains. We are working on a resolution.
Posted Apr 25, 2019 - 12:19 EDT
This incident affected: Domains.