New Domain Registration Under Maintenance
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Dec 07, 2019 - 23:10 EST
Update
We are continuing to work on a fix for this issue.
Posted Dec 07, 2019 - 22:27 EST
Identified
Customers who are attempting to register new domains will be unable to do so for the next few hours due to maintenance. Existing domain names are not affected by this and will continue to function. We will post an update when that maintenance is complete.
Posted Dec 07, 2019 - 21:54 EST
This incident affected: Domains.