Connectivity Issues
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Sep 13, 2017 - 15:00 EDT
Identified
We have identified a issue with an upstream network provider and made a configuration change to resolve the issue.
Posted Sep 13, 2017 - 14:50 EDT
Investigating
We are investigating connectivity issues affecting page loads for some visitors. Our network team is investigating with our upstream providers.
Posted Sep 13, 2017 - 14:42 EDT