Customers unable to connect domains
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Mar 25, 2020 - 18:00 EDT
Update
We are continuing to monitor for any further issues.
Posted Mar 25, 2020 - 17:53 EDT
Update
We are continuing to monitor for any further issues.
Posted Mar 25, 2020 - 17:52 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2020 - 17:27 EDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 25, 2020 - 17:10 EDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 25, 2020 - 16:54 EDT
Identified
The issue has been identified and we're working on a fix.
Posted Mar 25, 2020 - 16:37 EDT
This incident affected: Domains.