Loading issues with Squarespace.com
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Dec 12, 2022 - 14:19 EST
Monitoring
We are currently investigating an issue where login.squarespace.com is not available. This may prevent users from logging in to their sites. We have identified the issue and are monitoring a fix.
Posted Dec 12, 2022 - 14:14 EST
Investigating
We are currently investigating an issue where login.squarespace.com is not available. This may prevent users from logging in to their sites.
Posted Dec 12, 2022 - 14:00 EST
This incident affected: Site Loading and Site Editing.