Some Customers Unable to Log In
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Sep 22, 2020 - 19:18 EDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 22, 2020 - 19:06 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 22, 2020 - 18:18 EDT
Investigating
We're currently investigating an issue where some users are unable to log in using two-factor authentication.
Posted Sep 22, 2020 - 18:14 EDT
This incident affected: Accounts & Billing.