Issue with Commerce Subscriptions
Incident Report for Squarespace
Resolved
The incident has been resolved. We will be contacting the merchants impacted and rectifying their erroneous charges.
Posted Apr 15, 2019 - 22:48 EDT
Monitoring
At 5PM Eastern Time, a fix was implemented and we have been monitoring the results. We are working on identifying all merchants impacted and rectifying their erroneous charges.
Posted Apr 15, 2019 - 17:00 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 15, 2019 - 16:55 EDT
Update
The issue has been identified and a fix is being implemented
Posted Apr 15, 2019 - 16:55 EDT
Investigating
Commerce subscription payments were processed earlier than scheduled, and we are working on a fix
Posted Apr 15, 2019 - 16:50 EDT
This incident affected: Commerce.