Squarespace Help Center Issues
Incident Report for Squarespace
Resolved
These issues have been resolved.
Posted Oct 13, 2016 - 16:41 EDT
Investigating
We’re looking into issues with contacting us through the help site. For help, email us directly: customercare@squarespace.com
Posted Oct 13, 2016 - 13:53 EDT