Issues uploading images
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Mar 23, 2020 - 11:16 EDT
Update
We are continuing to monitor for any further issues.
Posted Mar 23, 2020 - 11:11 EDT
Monitoring
We're investigating errors when uploading images to Squarespace sites.
Posted Mar 23, 2020 - 11:08 EDT
This incident affected: Site Editing.