We are investigating connectivity issues impacting all Squarespace sites.
Incident Report for Squarespace
Resolved
This issue is now resolved.
Posted Oct 14, 2016 - 15:05 EDT
Monitoring
A routine upgrade to a shared resource failed, causing connectivity issues. We have resolved this issue and sites should be recovering.
Posted Oct 14, 2016 - 15:03 EDT
Investigating
We are currently investigating this issue.
Posted Oct 14, 2016 - 14:58 EDT