Unable to update payment details
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Oct 11, 2017 - 15:50 EDT
Identified
Users are currently unable to change their billing details. The problem has been identified and a fix will be deployed shortly.
Posted Oct 11, 2017 - 14:33 EDT