Errors with Billing and Domain Access

Incident Report for Squarespace

Resolved

This incident has been resolved.
Posted Aug 28, 2025 - 16:43 EDT

Update

We are continuing to monitor this issue.
Posted Aug 28, 2025 - 16:18 EDT

Update

The issue was mitigated, but we are continuing to monitor it.
Posted Aug 28, 2025 - 16:02 EDT

Update

We are continuing to monitor this issue.
Posted Aug 28, 2025 - 15:43 EDT

Monitoring

The issue has been mitigated, and we are currently monitoring the results.
Posted Aug 28, 2025 - 15:17 EDT

Identified

We've identified an issue affecting billing and domain access, and our team is actively working on a fix.
Posted Aug 28, 2025 - 14:55 EDT
This incident affected: Domains and Accounts & Billing.