Account Dashboard Issues
Incident Report for Squarespace
Resolved
This incident is now resolved.
Posted Jun 15, 2017 - 15:55 EDT
Identified
We have identified an issue with our routing layer. We are pushing out a fix.
Posted Jun 15, 2017 - 15:22 EDT
Investigating
We are investigating issues while loading the account dashboard for Squarespace websites.
Posted Jun 15, 2017 - 15:18 EDT