Limited Account Dashboard Functionality
Incident Report for Squarespace
Resolved
Our engineers have fixed the underlying issue, and all customers are now able to access their account dashboard.
Posted Dec 06, 2019 - 08:42 EST
Identified
Some customers are experiencing issues when attempting to access their account dashboard. We have identified the root cause and are implementing a fix.
Posted Dec 06, 2019 - 08:31 EST