Connectivity Issues
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Feb 10, 2018 - 20:39 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 10, 2018 - 20:35 EST
Investigating
We are investigating connectivity issues related to most Squarespace sites. We will provide more information as soon as possible.
Posted Feb 10, 2018 - 20:26 EST