Connectivity issues
Incident Report for Squarespace
Resolved
Connectivity and performance has returned to normal.
Posted Oct 11, 2016 - 15:18 EDT
Identified
Connectivity is improving. Pages are loading slower than normal.
Posted Oct 11, 2016 - 14:56 EDT
Investigating
We are investigating reports of connectivity issues affecting all sites.
Posted Oct 11, 2016 - 14:16 EDT