Email Delivery Issues
Incident Report for Squarespace
Resolved
This incident has been resolved and we have confirmed that all systems are operational. Thank you for your patience.
Posted Apr 24, 2019 - 16:54 EDT
Monitoring
A resolution has been implemented and we are monitoring closely before resolving the issue.
Posted Apr 24, 2019 - 16:21 EDT
Investigating
We are investigating email delivery issues. We will provide more information as soon as possible.
Posted Apr 24, 2019 - 15:40 EDT
This incident affected: Site Loading.