Connectivity issue
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Oct 21, 2016 - 10:09 EDT
Update
Services have resumed for many of our customers. The situation continues to improve.
Posted Oct 21, 2016 - 09:23 EDT
Update
Our primary DNS provider is under a major DDoS attack. This is affecting a large number of companies across the world. We are actively pursuing a resolution and also working with our partners.
Posted Oct 21, 2016 - 08:14 EDT
Identified
We have identified an issue with our DNS provider and are actively investigating.
Posted Oct 21, 2016 - 07:28 EDT
Investigating
We are investigating a connectivity issue related to www.squarespace.com.
Posted Oct 21, 2016 - 07:27 EDT