Login Issues
Incident Report for Squarespace
Resolved
This incident has been resolved and we have confirmed that customers logins are now functioning normally. Thank you for your patience.
Posted Feb 22, 2017 - 19:13 EST
Monitoring
A fix has been deployed. Our engineers will continue to monitoring closely.
Posted Feb 22, 2017 - 19:00 EST
Identified
We have identified the issue and are deploying a fix.
Posted Feb 22, 2017 - 18:30 EST
Investigating
We are currently investigating an issue affecting customer logins.
Posted Feb 22, 2017 - 18:16 EST